Towedm的新特性

Towedm具有如下诱人的新特性：

1、完全兼容Autop，界面、操作习惯与绘图思想同Autop如出一辙。绝大数功能你都可以在同Autop相似的地方找到。鼠标风格甚至可以设置成同Autop一样的右键风格。
2、鼠标和快捷键互用，提供更快捷的作图方式。鼠标操作已焕然一新，再辅以贴心的、充分人性化的快捷键设置，相信定能使你的工作轻松不少。
3、数据录入方式灵活多样：支持相对坐标、相对极坐标、支持省略输入和代数式输入,有效降低数据录入工作强度。
4、更完备和更健全的功能，如：等分直线、圆、圆弧，直线、圆弧延长，角平分线和块缩放功能使绘图功能更加健全。另外，Autop在作“点切+半径”时当点在圆内时无法操作、三切圆常常可选个数不够等等这些缺陷在新的Towedm软件中都已一扫而空。
5、查询、移动、窗口、缩放等辅助功能更方便操作。查询被设置成了常用命令，并支持连续查询。移动能够键盘连续移动和鼠标连续移动。选定要放大显示的窗口时，不再强制要从左下角到右上角。可以输入数值比例缩放、也可以使用用按键（PageUp、PageDown）连续缩放。
6、在保留旧风格、旧习惯的同时充分考虑同潮流接轨。如：Towedm改Autop传统的用“PageUp”和“PageDown”来调节光标移动速度为“Home”和“End”,而将“PageUp”和“PageDown”定义为图形缩小放大功能键，就是充分考虑的当前流行软件的定义。同样的考虑还有代码传输类型的名称定义、代码生成时对起始点和切入点的处理等。
7、操作更大的文件和更快地操作文件。实际上，Towedm能操作多大的文件并不由软件决定，而仅信赖于你的内存，一个例子是，在不到10兆的内存上生成一个2模2000齿的齿轮并生成代码（总代码条数超过一万条），全部操作只需要不到10秒钟，这一点就是连CAXA都做不到。
8、良好的软件接口环境增强了Towedm的协同工作的能力。现在——已经不是用同一个软件自始至终完成所有作图的那个年代了，我们需要协同作战。Towedm现在已提供了Dxf转Dat、Dat转Dxf、3B/4B转Dat三项功能，并将计划在未来提供更多的接口功能。
9、更好的运行稳定性和更强的联机功能。最低端Towedm支持486DX和Dos6.22，最高端Towedm支持P4和Windows95/98/Me。联机代码充分吸收了当前联机标准之一的CAXA的特点，并加以改进，能充分适应多家控制器和Dos与Windows两种环境下的传输。Towedm还独创性地把联机部分做成了驱动形式，并公开驱动开发源代码，充分保障了用户和控制器生产厂家自行开发联机驱动、解决联机问题的可能性。
10、无限可扩充的软件插件模块设计。对于数据接口和高级曲线这类随用户不同而要求不同的功能，Towedm将其做成了插件形式，并开放插件接口定义，使软件具有了无限可扩充的能力。

阿松工作室·版权所有
http://www.hsoft.cn


安装指南

安装要求

硬件配置

486DX以上PC或其兼容机。
5兆以上基本内存。
10兆以上硬盘剩余空间。
两键或三键鼠标。
建议586以上PC或兼容机，10兆以上基本内存，200兆以上硬盘剩余空间。

软件环境

Dos6.22以上Ms-Dos磁盘操作系统，或Win95/98/Me。
建议使用Windows98第二版。

安装步骤

1、下载Towedm安装压缩包，然后解压缩。
2、要从Dos下进行安装，请运行Setup.exe，要从Windows下进行安装，请运行Setup32.exe。（注意：Setup.exe和Setup32.exe不能被放置在磁盘根目录。）
3、安装完成后，Windows用户会在桌面看到指向其启动的快捷方式，Dos用户会在C盘根目录看到指向其启动的批处理（T.bat）。

加密锁使用说明：

为确保加密锁正常有效工作，请
1、 插拔加密锁前请关闭计算机、关闭电源。
2、 加密锁工作期间让计算机可靠接地。
3、 拧紧加密锁两端的螺钉。

如遇加密锁不能工作，可作如下测试，
1、重新正确安装软件，以恢复可能被破坏的文件。
2、重新插拔加密锁，并拧紧螺钉。
3、检查计算机打印口看是否损坏。
4、将加密锁插到另外一台计算机上，看其使用是否正常。


如何注册

注册详情详见我们官方网站说明:

http://hsoft.cn 或者

http://cn1in.cn

QQ:554807875 | 手机:13995992335 | E-mail:towedm@163.com


联机设置

端口号设置：端口号其有三项：0x278,0x378,0x3BC，系统默认为0x378,一此较老的电脑此数值常为0x3BC，此时请根据电脑的实际情况予以更正。
一般地来说，应答传输的控制器多为数据信号低电平有效，同步传输多为数据数据信号高电平有效，但也有例外，如果你的控制与默认设置的不同，请更正。
同步传输的信号保持时间可以用来调整同步传输的速度。保持时间越大，传输越慢，保持时间越小，传输越快。


设置暂停码

设置暂停码。提供四个选项。

1、无暂停码。
2、B0B0B0 HALT格式的暂停码。
3、B0B0B0GXL1格式的暂停码。
4、暂停码D。
请根据你控制器的具体情况设置。


其它设置

数据查询精度帮助设定查询时小数点后显示的位数。
代码查看行数设定每屏可查看的代码行数，0表示最大行数。
发送文件夹设定你在文件管理器里按下发送时文件将被复制到的文件夹。
如果你习惯Autop传统的右键风格，请将"鼠标右键确定"选中。


打开文件

打开一个线切割图形文件进行再编辑。
可以通过打开一个不存在的图形文件来新建文件。（输入一个不存在的文件名）
Windows用户如果在安装时选择了“注册文件关联”的话，也可以在资源管理器中通过双击一个线切割图形文件的方式来打开一个文件。


并入文件

并入一个线切割图形文件。


文件存盘

将当前正在编辑的图形文件存盘。


文件另存为

将当前正在编辑的线切割图形文件换一个文件名存盘。
存盘后当前文件名即为新的文件名。


数据接口

共有三个选择:
1、并入CAD文件，将AutoCAD的Dxf格式图形文件并入当前正在编辑的线切割图形文件。
2、将当前正在编辑的线切割图形文件输出为AutoCAD的Dxf格式图形文件。
3、将线切割的3B/4B代码转换为线切割图形文件并并入当前正在编辑的文件。


备份操作

要设置备份文件夹，在系统设置的其它页中直接按退格键删去原设置，然后输入新的设置即可。
要备份一个文件。可以在打开、并入、或保存文件时按下备份按钮，文件将被备份到你所设定的备份文件夹中。
要备份多个文件，可以在打开、并入、或保存文件时选定一个文件按下F10键设置备份起点，选定另一个文件再次按下F10键设置备份终点。两个文件间的文件将被备份到你所设定的备份文件夹中。
要备份某个时间段的文件，在备份多个文件前先按下F7键，使文件按时间排序。


暂存系统

返回Windows以便执行其它的操作，譬如再打开一个线切割图形文件进行编辑。按任意键返回。
当在纯Dos下运行Towedm时，此菜单显示为“命令提示符”,可进入Dos提示符执行一些临时的操作。输入“EXIT”返回。


点菜单

坐标点

根据输入坐标值绘制点，支持相对坐标、相对极坐标。支持省略输入和代数式输入

光标任意点

在光标点击的当前位置作点。

圆心点

求已知圆或圆的圆心点。

圆上点

根据给定圆和点在圆上的角度绘制点。

等分点

等分直线、圆或圆弧。

点阵

从已知点阵端点开始，以点阵距离（Dx,Dy）为步距，X轴数为X轴上点的数目，Y轴数为Y轴上点的数目作一个点阵列。改变步距Dx,Dy的符号就可以改变点阵端点为左上角、左下角、右上角和右下角。
可使用此功能配合辅助作图，能加快作图速度。数控程序的阵列加工也需要此功能配合。

中点

等分点的特例，作直线、圆弧的中点。

两点中点

已知两点，求中点。

CL交点

求直线、圆、圆弧间的交点。如果有两个交点，只选取更靠近鼠标点击时光标处的交点。
不要求图元有可见相交点，计算时将直线延伸、圆弧延伸，然后求出其交点。

点旋转

旋转复制点。

点对称

求已知点的对称点。

查两点距离

计算两点间的距离，当在光标捕捉范围内能捕捉一个点时，取该点为其中一个点，否则，取鼠标确认键按下时光标所在位置坐标值。

删除孤立点

删除孤立的没有连接的点。

点评：等分点和相对坐标是两个亮点。


直线菜单

两点直线

已经两点作一条直线，交点可直线使用。

角平分线

作两给定直线的角平分线，结果为辅助线

点+角度

给定直线上一点和角度作线，结果为辅助线。

切+角度

已知切于圆、已知直线角度作辅助线。

点线夹角

已知直线上一点，已知直线与另一直线的夹角作直线。
当点在直线外时，角度为零，结果直线为选定直线的平行线（辅助线）;角度为90度，结果直线为点到两直线交点的一条实直线。
当点在直线上时，结果为与选定直线夹某一角度的辅助线。

点切于圆

已经直线上一点。并且该直线切于已知圆作直线。
当点在圆上时所作直线为过该点切于圆的切线（辅助线），当点在圆外时，为连接该点和直线圆切点的实直线。

两圆公切线

作两圆或圆弧的公切线。
如果两圆相交，可选直线为两圆的两条外公切线。
如果两圆不相交，可选直线为两圆的两条外公切线加两条内公切线。

直线延长

延长直线直至于另一选定直线、圆或圆弧相交。

直线平移

平移复制直线。
如选定直线为实直线，复制后也为实直线.如选定直线为辅助线，结果也为辅助线。

直线对称

对称复制直线。

参照线

又叫坐标线，作过已知点的水平和垂直两条辅助线。

清除辅助线

删除所有辅助线。

查两线夹角

求两已知直线的夹角，角度值将按照逆时针方向给出。

点评：直线延长是许多老Autop用户期盼已久的功能。


圆菜单

圆心+半径

给定圆心和半径作圆。

圆心+切

已知圆心，已知圆相切于另一已知点、直线、圆或圆弧作圆。

点切+半径

已知圆上一点，已知圆与另一点、直线、圆或圆弧相切，并已知半径作圆。

两点+半径

已知圆上两点，已知圆半径作圆。

心线+切

给定圆心所在直线，并相切于一已知点、直线、圆或圆弧作圆。

双切+半径

与两已知点、直线、圆或圆弧相切，并已知半径作圆。

三切圆

与已知三点、直线、圆或圆弧相切，作圆。三点圆用此功能作出。

圆弧延长

延长圆弧与另一图元相交。

同心圆

将圆或圆弧按给定数值偏移。

圆对称

作圆或圆弧的对称圆、圆弧。

圆变圆弧

将选定圆按给定起始角度和终止角度编辑变成圆弧。

尖点变圆弧

当两图圆元相交并且端点重合时，可用此功能为它们在端点重合处添加一过渡圆弧。必须保证尖点只有两个有效图元（此处只能是直线或圆弧）且端点重合，否则此操作不能成功。

圆弧变圆

变圆为圆弧。

点评：圆弧延长是许多老Autop用户期盼已经的功能。


块菜单

窗口选定

所有包含在选定窗口内的图元被置块标志，显示为洋红色。
可以从任意一个角开始到任意一个角结束画选定矩形。（没有Autop那样的必须从左下角到右上角的限制）

增加块元素

置选定有效元素为块元素。

减少块元素

置选定有效图元为非块元素。

取消块

取消所有图元的块标志。将所有图元恢复为非块。

删块块元素

将所有置块标志的图元删除。

块平移

平移复制块。

块旋转

旋转复制块。

块对称

对称复制块。

块缩放

将块元素的图形尺寸进行缩放。
许多Autop的安装包中都有一个第三方开发的小程序，执行图形的缩放功能，这里块缩放实现的是同样的功能。

块统计

统计当前块里直线、圆和圆弧的个数，可用此功能来发现是否有重合的线条。

反向选择

置非块元素为块元素，同时取消块元素为非块元素。

全部选定

置所有有效图元为块元素。

点评：块缩放是Towedm与Autop相比最实用的一个功能。


高级曲线

椭圆

有五个参数：长半轴、短半轴、起始角度、终止角度，旋转角度。

多边形

可作三种类型的多边形，分别是圆外切多边形、圆内接多边形和已知边长的多边形。
有四个参数：边数、类型、参数，起始点角度。

抛物线

使用抛物线方程Y=K*X*X。
四个参数，K值，起始参数,终止参数,旋转角度。

渐开线

四个参数：基圆半径、起始角度、终止角度、旋转角度。

标准齿轮

四个参数：模数、齿数、有效齿数、起始点角度。
注意不要使有效齿数大于齿数，这里虽然也能作出图形，但会有许多重复的线条，在生成加工代码时会造成麻烦。

自由齿轮

参数比较多，有模数、齿数、变位系数（标准齿轮此值为0），压力角（标准齿轮此值为20度）、齿顶高系数（标准齿轮此值为1）、齿顶隙系数（标准齿轮此值为0.25），齿根圆弧系数（标准齿轮此值为0.38）、有效齿数和起始点角度。

阿基米德螺线

五个参数：起始点角度、起始点半径、终止点角度、终止点半径，旋转角度。

点评：希望能看到更多的高级曲线功能。


交点操作

捕捉交点。要求交点在两相交图元内。

点评：交点都已经可以直接选取了，此功能还留在此有点画蛇添足。除了能给一些老Autop用户养养眼外，已经一无是处了。


打断操作

要执行打断先要确定在你要打断的直线、圆或圆上有两个点存在。
执行打断后光标所在的两点间的图元部分被剪掉。
如果在执行打断操作前预先按下Ctrl键，将执行反向打断。此时光标两点间的图元被保留，其余的部分被剪掉。
辅助线不能被打断。

点评：反向打断，一个挺不错的功能设计。


删除操作

删除选定的点、直线、圆或圆弧。
输入“ALL”将删除所有图形。

评论：没有评论。


取消操作

恢复至上一次操作前的状态，如果上一次操作中绘制了图元，就将它删除，如果上一次操作删除了图元，就将它恢复。

点评：没有评论。


重做操作

将上一次取消操作中删除的图元或其它操作中删除的图元恢复，将上一次取消操作恢复的图元再删除。
只支持一步重做操作。

点评：如果错误地使用了删除操作现在有了恢复的可能，遗憾的是只能执行一步此类操作。


窗口操作

将选定矩形(窗口)内的图形放大显示。

点评：当选定要放大的窗口矩形时比Autop灵活，没有非要从左下角至右上角的限制，可以从任一角开始，到任一角结束。


缩放操作

将图形按输入的缩小放大倍数缩小放大显示。

除了按以上方式缩小放大图形外，也可以在作图的任一时候，按下PageDown执行缩小、PageUp执行放大功能。

点评：按PageDown、PageUp缩小放大的功能非常好，可惜有一点缺陷，每次第一次按下PageUp和PageDown时图形都没有显示，以后才正常，希望在以后的版本里改进。


满屏操作

满屏显示图形，显示所有图形。

点评：没有评论。


移动操作

操作方法：执行移动功能，当光标为十字线时按下鼠标确定键或敲回车键，使光标变为一四向箭头，再移动光标就可以移动图形了。
要结束移动状态只要再次按下鼠标确定键或再次敲击回车键就可以，光标将同时变回为原十字线图形。

也可以作图的任一时候，按下G（向左）、Y（向上）、J（向右）、N（向下）来执行移动操作。

点评：比Autop那个莫名奇妙的移动图形功能好多了。


相对操作

相对平移

相对平移当前图形文件。（平移不复制）

相对旋转

相对旋转当前图形文件。（旋转不复制）

对称处理

将当前图形文件作对称处理。

取消相对

取消已执行的相对操作。

输出窗口

输出窗口为一幅位图，如果不指定完全路径的话，该位图将被保存在文件夹Demo里。可将此位图用于打印。

1:1位图

输出1：1的位图。可将此位图用于打印，打印的图形即为1：1图形。

输出全屏

输出整个屏幕为一幅位图。

打印代码

如果在Windows下运行Towedm的话，建议使用记事本或其它Windows程序来打断代码，效果将要好得多。


清屏操作

隐藏所有图形。

点评：一张白纸，好画最美的画。此一功能有化繁为简的独特功效。


上一屏图形

按上一次被改变的缩放比例和窗口位置显示图形。

点评：很好的功能，可以说是Autop同其它许多线切割相比的一个精彩点。


计算器

Towedm的计算器，可以计算加（+）、减（-）、乘（*）、除（/）、乘方（^）和三角度函数正弦（Sin）、余弦（Cos）、正切（Tan）、余切（Cta）、反正弦(Asin)、反余弦(Acos)、反正切(Atan)。

点评：好功能。


加工路线

执行主菜单中的数控程序->加工路线，将开始B代码的生成过程。
Towedm可以生成3B、LRB和D4B三种格式的加工代码。在代码生成的操作方式上，兼容了Autop传统的实引线和流行的无实引线两种方式，补偿方向用箭头加正负号直接给出，免去了用户自己判断所可能造成的差错。其具体操作步骤如下：

1、选定代码类型。1为3B，2为LRB，3为D4B。
2、选择加工起始点和切入点。
3、回答加工方向。（Yes/No)。
4、给出尖点圆弧半径。
5、3B给出补偿间隙，请根据图形上箭头所提示的正负号来给出数值。
4B给出加工起始点在图形内，还是在图形外的信息，请按照实际情况给出。
6、操作完成后如果无差错即会给出生成后的代码信息，有错误则给出错误提示。提示信息格式如下：

尖点圆弧 | 间隙补偿 | 路线总长 | X轴校零 | Y轴校零
R= | F= | L= | X= | Y=

如果要为4B设置补偿，请将系统设置里的4B不补偿改为4B补偿。


取消旧路线

取消当前加工路线。


代码存盘

加工代码存盘。
如果当前新建文件文件名为空必须先将图形文件存盘。
3B代码存盘后扩展名为“.3B”，4B代码存盘后扩展名为“.4B”。


轨迹仿真

标注加工代码的加工次序。


起始对刀点

当生成的加工代码的起割点不是要求的起点时，可使用此功能将其引导到需要的起点上去。


终止对刀点

当生成的加工代码终止点不是要求的终止点时，可以用此功能将它引导到要求的终止点上去。


旋转加工

旋转加工代码。


阵列加工

可选用点菜单中的点阵生成需要的点阵，再点击各个跳步程序的起始点来生成阵列。

点评：虽然生成点阵麻烦了些，但可以自由决定加工次序，总算是还算值得。


加工计费

给出工件厚度，给出工价，计算当前加工工件的工价。


查看代码

查看当前生成的加工代码。
使用查看代码功能还可以直接修改已生成的加工代码，修改有编辑和插入两种状态。当当前状态不是你所需要的状态时，可以按下"Insert"键切换当前状态。直接按下"B"或"L"或"D"或即可进入编辑或插入状态。要编辑成或插入停机指令，请按下字符"E"。


载入代码

从已存盘的加工代码中载入代码。


应答传输

在Autop里此功能被称作“送数控程序”。


同步传输

在Autop里此功能被称作“穿数控纸带”。


快捷键

在Towedm的主程序中除了全部菜单都使用了快捷键外，还提供了以下的快捷键。

Home：加快光标移动速度
End：减慢光标移动速度。
PageUp 放大图形。
PageDown 缩小图形。
Y：向上移动图形。
N：向下移动图形。
G：向左移动图形。
J：向右移动图形。
F4：刷新图形不画点。
F5：刷新图形（画点、画辅助线）。
F6：刷新图形不画辅助线。
F10：重画加工路线。

在文件管理器里你还可以使用以下快捷键。

F6：按文件名排序。
F7：按时间排序。
F10：批量备份文件。
Delete：删除一个文件。
Esc/F3：退出文件管理器。


数据录入格式

点录入格式：

1、普通输入格式：x,y
2、相对坐标输入格式：@x,y
3、相对极坐标输入格式：<x,y
（注：相对点在界面上显示为绿色小矩形）
4、省略输入：当x坐标与前一数值相同时可省略x值，格式（,y），当y值与前一数值相同时可省略y值，格式（x）或（x,）。
5、代数式输入，输入格式为：代数式1,代数式2
其中，代数式支持加(+)、减(-)、乘(*)、除(/)、乘方(^)和一些常用数学函数（Sin正弦,Cos余弦,Tan正切,Cta余切、Atan反正切、Asin反正弦、Acos反作弦、Sqrt开平方）。

直径录入格式：

当输入半径时在数值前加“D”即将输入数值认为直径。


联机驱动开发说明及示例

/********************************************************
以下是一段Towedm联机程序的源代码，
希望有能力的朋友看了以后能有为Towedm开发联机驱动的冲动。
Towedm采用驻留的TSR程序作为它的联机驱动。
许多人把这种程序看得高深莫测，其实很简单，最关键的代码我都已经为你解决了。
你需要的就是根据你所拥有的控制器的具体情况往里面填写一些简单的代码。
以下是一个简单的例子，完成高电平有效同步传输的功能，
程序在台州全部同步传输的控制器和杭无专的控制器上测试通过。
程序用BC3.0在TINY模式上编译链接成功。

自己动手编写联机驱动真的不是很难!!!
***********************************************************/

#include 〈dos.h〉

#include 〈bios.h〉

#define INTR60 0x60 //60h号用户中断

#define INTR61 0x61 //61h号用户中断

#ifdef __cplusplus

#define __CPPARGS ...

#else

#define __CPPARGS

#endif

//这段代码完成发送代码到打印端口的任务，

//由于使用内联汇编写成，所以代码相当紧凑。

//同样的功能，Autop用了太多的语句。

//一般地，你可以将它直接用到你的驱动程序中，无需要改动。

void sendcode(int type,unsigned char code)

{

asm mov al,code;

asm sub al,0x30; //为方便起见，Towedm传送过来的数据被加上了30h,因此这里先减30h.

asm jp LOC2; //跳则无需添加校验位。

asm add al,0x10; //添加校验位。

LOC2:

asm cmp type,1;

asm jb LOC3;

asm add al,0x20; //添加同步信号。

LOC3:

code=_AL;

outportb(0x378,code);

}

//如果有研究过Autop传输代码的高手的话，应该知道这段代码同Autop的并不相同

//是的，它是CAXA的，老Autop的传输代码并不适应于Windows和高速电脑。

//下面，你需要根据你自己控制器的实际情况来修改以下这段代码。

void interrupt handler60(__CPPARGS)

{

unsigned char code,type;

code=_AL; //由Towedm主程序传过来的数据，B代码数据。

if(code>0x3f) return; //不要省掉这行。

disable(); //关中断。

/******************仅仅需要修改下面这四行代码*********************/

sendcode(0,code); //第一次发送无同步位信号。

delay(4); //延时。

sendcode(2,code); //第二次发送添加同步位信号。

delay(8); //延时。

/******************仅仅需要修改上面这四行代码********************/

enable(); //开中断。

}

//Towedm用61号中断来通知TSR驱动读取联机设置

//请不要省去下面这几行代码，否则你会死机，而且死得很惨哦！

void interrupt handler61(__CPPARGS)

{

}

void main()

{

if(getvect(INTR60)!=0) return; //避免多次载入。

setvect(INTR60, handler60); //设置中断号。

setvect(INTR61, handler61); //设置中断号

keep(0,_SS+((_SP+2)/16)-_psp); //驻留内存。

}

//编译完成后请将使用二进制编辑工具在你的程序未尾加上字符串COMMUNICATION,

//并将其命名为LDriver.exe，这样Towedm才认可其为一个联机驱动。否则会提示检测不到联机驱动的错误。

如果在开发过程中有任何疑难之处，欢迎随时与我联系。


Autop高级使用技巧六则

一、 Autop快捷键知多少
Delete 删除图元，很少有人不知道了。
但是：
E 刷新图形不画点。
R 重画一遍图形
T 重画一遍加工路线
这些你知道吗？
如果你输入直径，你可以在直径数值前加“D”。

二、 Autop求圆心最快捷方法
使用点菜单中的“XY点”指向待求圆心的圆或圆弧，即可求出圆心。

三、 传输也能调快慢。
CAXA的同步传输能调快慢，为什么Autop穿数控制纸带不能呢？
下载阿松的Autop56。用记事本打开文件“$$.BAT”，将其中的4改大些，Autop的传
输速度就慢了些，将数值改小，Autop的传输速度就快了起来。

四、 鼠标左右键能设定
从http://towedm.yeah.net下载一个鼠标键设置程序“mset.exe”，在Autop文件夹中，执
行“MSET L”，Autop就成左键风格，执行“MSET R”，Autop就成右键风格。

五、 联机从此更稳定
如果你在Windows下运行Autop的话，以下技巧能使你的传输更加稳定。
打开Autop快捷方式的属性页，禁止“杂项”页中的“允许启用屏幕保护程序”。在“屏
幕”页中，启用“全屏幕”。在“程序”页中，启用“退出时关闭”，在其高级中，启用“禁
止Ms-Dos程序检测Windows”。
当然，如果你下载安装Autop56的话，这些在安装时都已经为你配置好了，你无需自己
改动。

六、 1：1打印也简单。
Autop能作1：1打印吗？当然不能，但是以下方法将帮助你轻松实现1：1打印。
在“查两点距离中”，按住键盘向上方向键，移动光标至最高点，确定为点一，按住向
下方向键，移动光标至最低点，确定为点二。用这两点的距离除以113.24167，用得出的值
作为放大缩小倍数，缩放图形。按“Print Screen”键打印屏幕，在画图中粘帖图形，然后将
图形改为黑白图形，再反色，打印出来就是1:1图形了。


实例一

1、以原点为圆心、40为半径作一大圆。
2、将X轴向上平移80。取其与Y轴交点为圆心，10为半径作一小圆。
3、将X轴向下平移40、Y轴向左平移20，过两线交点作小圆的切线（点切于圆）。作切线与大圆的交点，打断切线下半部分。
4、作大圆与小圆靠右边的外公切线。过圆心作一半径为60的圆，延长外公切线与此与半径为60的大圆相交。删去半径为60的大圆。
5、过直线与半径为60大圆的交点作半径为40大圆的切线。
6、在小圆另一切线与大圆的交点处执行尖点变圆弧，圆弧半径为20。


实例二

1、以原点为圆心、10、20、37为半径作三个圆。）
2、将半径37的圆五等分，起始角度0。以等分点为圆心作半径为7的圆。
3、将半径20的圆五等分，起如角度36。以等分点为圆心作径为3的圆。
3、将X轴向上向下分别平移2。
4、连接圆心与角度为36的等分点成直线，将直线向正反两方各平移1.5。
5、连接交点成直线。打断图形多余的部分。


实例三

1、将X轴向上平移40。Y轴向左平移40。
2、取其交点为圆心，15为半径作左边的小圆。
3、Y同向右平移40取其交点为圆心，15为半径作右边的小圆。
4、以原点为圆心作一半径为20的圆。
5、作以上三圆的外公切圆和内公切圆。（三切圆）
6、作两公切圆与上部两小圆的交点。作外公切圆与半径20的圆与X轴的交点。
7、打断图形多余的部分。


实例四

1、将X轴向上平移10。取其与Y轴交点为圆心，5.1为半径作一圆。
2、将X轴向上平移25、取其与Y轴交点为圆心，8.2为半径作另一圆。
3、作两圆的两条外公切线。
4、将X轴向上平移35、将过原点的参照线Y轴向左向右各平移2。连接交点成实直线。
5、打断两圆多余的部分。
6、将图形全部选定为块，然后执行块旋转旋转120度，旋转两次。


实例五

1、将X轴向下平移30-4，以Y轴为心线作心线+切，半径15。
2、将Y轴向左向右各平移56/2，以X轴为心线两次作心线+切，半径20。
3、以原点为圆心作两大圆，半径分别为70、86。
4、过原点作点+角度直线，角度90-10，平移直线与两大圆相交。
4、X轴向上平移48，Y轴向左向右各平移38。
5、连接交点成实直线。在交点处执行尖点变圆弧。分别为R5四处，R7两处，R3两处。
6、打断图形上多余的部分。


实例六

1、将X轴向上向下各平移35，Y轴向右平移60。
2、取其交点为当前点作相对极坐标点（〈140，15）,以该极坐标点为圆心，15为半径作一小圆。 2、以原点为圆心，40为半径作一大圆。
3、连接大圆与高度35的水平辅助线在Y轴右边的交点及极坐标点（〈200，80）为一条直线。
4、过直线左端点作直线（点+角度，角度90度）交于高度-35的水平辅助线。
5、连接直线下端点与高度为-35的辅助线同大圆的左交点为实直线。
6、作小圆与高度35辅助线交点，打断小圆，连接其它需要连接的直线。
7、在交点处执行尖点变圆弧，圆弧半径2。


鸣谢

Towedm在推出的过程中曾得许多朋友的大力帮助，在此一并感谢。
感谢凝华电加工论坛为我提供了一个获得资讯的场地。
感谢网友简、阿文、zyp185、daizxl为此软件提出的许多意见。
感谢中国线切割网和中国模具网许多朋友此软件的关心。


Towedm操作举例

  1. 当连续输入坐标点时，Towedem的相对坐标输入和极坐标输入是很方便的。即在坐标数值前加@表示相对坐标（如：@20，30即表示相对于前一坐标点左移20，上移30确定一个点），加<表示极坐标（如<30,50 即表示相对于选定点与X轴夹30度角，极径为50的地方确定一个点。）

  2. 延长相交。有直线延长和圆弧延长两种，方法为：先选定要延长的直线或圆弧，请将光标点击在需要延长的一端，选定要延长到的线、圆或圆弧，直线或圆弧将被延长到另一直线、圆或圆弧。

  3. 数值计算。按下F3键，Towedm将进入计算器的数值计算功能，可以计算加（+）、减（-）、乘（*）、除（/）、乘方（^）和三角度函数正弦（Sin）、余弦（Cos）、正切（Tan）、余切（Cta）、反正弦(Asin)、反余弦(Acos)、反正切(Atan)。如：50*（Cos(30)+30*Sin(30)），结果为793.30127。

  4. Autop的软件包里常有第三方开发的一个小程序K，完成对图形的缩小放大功能，相当有用，在Towedm里你可以使用块缩放功能来完成这项操作。当将所有图形全部选定为块，执行块缩放时完成的即是类似于K的功能。

  5. 反向打断。当打断一个上面有很多点的有效图元时，我们常常希望能只保留我们选定的部分、而打断其它部分，这时你就可以使用反向打断。方法为选定图元时先按下Ctrl键再按下确定键。

  6. 屏蔽选择。要选定直线或圆弧上的一个点常常是一件很难的事，原因是我们的鼠标常常不好用，这时候你就可以使用Towedm的屏蔽选择功能，具体为按下Shift键屏蔽非点（此时只会选定点）、按下Ctrl键屏蔽点（此时不会选定点）。

  7. 运行多个实例。按下主菜单中的暂存系统，然后按下Windows的开始键进入Windows桌面，再次启动Towedm，将可以创建Towedm的多个运行实例，同时编辑多个文件。

  8. 断点续传。如果使用应答传输的控制器，你还可以在传输中使用断点续传功能。即在传输出错时将中断处的代码条数减去1，作为重新开始传输的条数，即可免去大代码量出错时重复传输所耗费的大量时间。建议续传前控制器校零一下，并同软件给出的中断处校零值比较看结果是否相符。

  9. 自由移动和无极缩放。使用菜单中的移动功能可以操作光标作精密的移动。也可以在绘图中的任何时候按下Y（向上）、N（向下）、G（向左）、J（向右）使用图形的移动。按下PageUp和PageDown可以实现图形的无极缩放。

  10. 生成加工代码。Towedm也使用数控程序中的加工路线来生成加工代码。生成方式支持与Autop兼容的画出引线方式和其它线切割软件流行的引线不画出方式。当使用Autop兼容的画出引线方式时，将加工起始点和加工切入点置为同一点（引线起点），当使用线切割流行的引线不画出方式时，将加工起始点置为引线起点，切入点置为引线切入点。Towedm的加工补偿提示使用简头加正负号给出，免去了用户自行判断所可能引起的失误。


关于

关于Towedm

显示软件的版本信息。未注册版硬盘版会在这里显示你的机器码。加密锁版本会提示“试用模式，无法存盘”。

点评：唯一的用处，让你知道你使用的是否是最新版本。


关于Autop升级软件Towedm的简要介绍

Towedm是Autop的升级软件，对比Autop，Towedm不仅有继承更有发展，总结起来，Towedm有如下的十大看点，即：

  1. 风格同Autop完全一致，用过Autop的人可直接上手，无需学习即可完成向新软件的过渡。Towedm的菜单和操作风格同Autop都大致相仿，鼠标甚至还设置了“左键确定”和“右键确定”两种方式，方便了一些Autop老用户的使用习惯。
  2. 操作更灵活，功能更强大。Autop的出现是以操作灵活取胜的；Towedm的操作方式比Autop更灵活，不仅鼠标操作更方便，全部功能更配以贴心的快捷键。新增了计算器、线段等分、线段延长、数据接口和B代码导入等多项功能。
  3. Dos32位程序，操作编辑文件无限大。可有效编辑多达两万多条的图形代码，而且速度极快，这一点就是连CAXA都办不到。实际上，Towedm能编辑多大的文件已完全不依赖于程序而仅局限于你的电脑。
  4. 32位的特性还使Towedm能以高分辨率显示，做到真正同Windows的分辨率保持一致。对于使用高分辨率显示器的用户将因此获得额外的更大的作图区域。
  5. 文件编辑、预览、查找、管理等多项功能多位一体，使工作轻松自如。文件预览支持按文件名和按时间排序，自由设置的发送文件夹，可完全迁就你的使用习惯。支持中文目录和中文文件名的正确显示。
  6. 同CAD和其它线切割软件良好接口。对于CAD软件，Towedm提供了“CAD文件并入”和“导出CAD文件”等两项功能，支持AutoCAD的R14和R2000版本、支持多段线和椭圆的转换。对于其它线切割软件，Towedm提供了将3B（4B）代码转换为图形的功能，转换支持3B/LRB/D4B多种格式，并支持软件“XOY”所生成的非标准3B格式，支持手写格式。
  7. 可有效生成多种格式加工代码，如：3B/LRB/D4B，充分满足用户的要求。并支持3B/4B/LRB代码的直接导入和手工输入3B代码和对代码的再编辑。
  8. 支持486，支持P4，支持Dos6.22，支持Windows，真正的低成本解决方案，使你的电脑物尽其用。
  9. 无限可扩充的插件设计方案，隐含无限升级可能。对高级曲线这类用户用得少但要求杂的功能，Towedm将其设计成了插件形式，以便在以后的开发过程中不断补充，因此，即使主程序不作丝毫改动，仅靠新添加插件，用户也能使其所用软件功能不断扩充。

阿松工作室